About This File

Framework 7.6 Architecture

Copyright © 2000–2007 Genesys Telecommunications Laboratories, Inc. All rights reserved.
76fr_architec_10-2007_v7.6.001.00

The information contained herein is proprietary and confidential and cannot be disclosed or duplicated without the prior written consent of Genesys Telecommunications Laboratories, Inc.

About Genesys

Genesys Telecommunications Laboratories, Inc., a subsidiary of Alcatel-Lucent, is 100% focused on software for call centers. Genesys recognizes that better interactions drive better business and build company reputations. Customer service solutions from Genesys deliver on this promise for Global 2000 enterprises, government organizations, and telecommunications service providers across 80 countries, directing more than 100 million customer interactions every day. Sophisticated routing and reporting across voice, e-mail, and Web channels ensure that customers are quickly connected to the best available resource—the first time. Genesys offers solutions for customer service, help desks, order desks, collections, outbound telesales and service, and workforce management. Visit www.genesyslab.com for more information.

Each product has its own documentation for online viewing on the Genesys Technical Support website or on the Genesys Documentation Library CD, which is available from Genesys upon request. For more information, contact your sales representative.

Notice

Although reasonable effort is made to ensure that the information in this document is complete and accurate at the time of release, Genesys Telecommunications Laboratories, Inc., cannot assume responsibility for any existing errors. Changes and/or corrections to the information contained in this document may be incorporated in future versions.

Your Responsibility for Your System’s Security

You are responsible for the security of your system. Product administration to prevent unauthorized use is your responsibility. Your system administrator should read all documents provided with this product to fully understand the features available that reduce your risk of incurring charges for unlicensed use of Genesys products.

Trademarks

Genesys and the Genesys logo are registered trademarks of Genesys Telecommunications Laboratories, Inc., in the USA and/or other countries. All other trademarks and trade names referred to in this document are the property of other companies.

Technical Support from VARs

If you have purchased this software from a value-added reseller (VAR), please contact the VAR for technical support.

Technical Support from Genesys

If you have purchased support directly from Genesys, please contact Genesys Technical Support at the following regional numbers:

North and Latin America | 888-369-5555 or 506-674-6767 | support@genesyslab.com
Europe, Middle East, and Africa | +44-(0)-118-974-7002 | support@genesyslab.co.uk
Asia Pacific | +61-7-3368-6868 | support@genesyslab.com.au
Japan | +81-3-5649-6821 | support@genesyslab.co.jp

Before contacting technical support, please refer to the Genesys Technical Support Guide for complete contact information and procedures.

Ordering Information

For complete information on ordering Genesys products, please see Licensing Genesys Products (for 6.5 and earlier products) or Genesys 7 Licensing Guide (for 7.0 and later products).

Released by

Genesys Telecommunications Laboratories, Inc.
www.genesyslab.com


Framework Architecture Overview

Overview: Framework Architecture

The Genesys Framework, a mandatory part of any Genesys-based interaction management system, provides the functions which are required for the normal operation of any Genesys solution.

The Genesys Framework consists of four layers:

  • The Configuration Layer processes and stores all the data required for running Genesys solutions in a particular environment; it notifies clients of any configuration changes. The Configuration Layer also controls user access to a solution's functions and data.

  • The Management Layer controls the startup and status of solutions, logging of application maintenance events, generation and processing of alarms, and management of application failures.

  • The Media Layer enables Genesys solutions to communicate across media, including traditional telephony systems, voice over IP, e-mail, and the Web. This layer also provides the mechanism to distribute interaction-related business data within and across solutions.

  • The Services Layer generates the statistical data that is used for interaction processing and contact center reporting. It also enables solutions to communicate with various database management systems (DBMSs).

In sophisticated configurations using the Management Layer functionality, each layer depends on the layers below it to work properly.

Note: a Genesys installation depends on License Manager, a third-party application not shown in the diagram, for license control.


Printing This Help File

You can print a single topic (page) or all the topics (pages) within a single book. You cannot, however, print the entire Help file at once.

On the Table of Contents, select a topic or book and then do the following:

  1. Select the Print button.

  2. In the Print Topics dialog box, select either:

    • Print the selected topic

    • Print the selected heading and all subtopics

  3. Select OK.


Configuration Layer Overview

Configuration Layer

Overview: Configuration Layer

The Configuration Layer of Genesys Framework provides:

  • Centralized configuration-data processing and storage for one-time entry of any information about contact center entities that applications require to function in a particular business environment. Any number of applications can use this information.

  • An advanced, configuration data–distribution mechanism. This mechanism enables applications to read their configuration upon startup and to receive update notifications at runtime without service interruptions.

  • Comprehensive data-integrity control functions that prevent entry of illogical configuration data that might cause solution malfunction.

  • Advanced reconnection management which ensures that applications have up-to-date data after reestablishing connection to Configuration Server.

  • Access-control functions that regulate a user's access to solution functions and data, based on the access privileges set for each item.

  • Wizards that help users through the automated process of solution deployment.

  • Universal, open, Simple Object Access Protocol (SOAP) interface to the configuration, so that a broad range of third-party applications can read and write the information.

Warning! SOAP functionality is restricted to certain environments. For more information, refer to Genesys Interface Server (GIS) documentation for release 6.5 and later.

  • Support for geographically distributed environments.

  • Integration with external data sources, from which you can import configuration data to the Configuration Database.

  • Export of configuration data from the Configuration Database.

  • Secure data transfer between Genesys components using the Transport Layer Security (TLS) protocol.

See also Configuration Layer Architecture.


Configuration Layer

Configuration Layer Architecture

  • Configuration Server provides centralized access to the Configuration Database, based on permissions that administrators can set for any user to any configuration object.

  • Configuration Server also maintains the common logical integrity of configuration data and notifies applications of changes made to the data. Optionally, you can run Configuration Server in Proxy mode to support a geographically distributed environment. (The geographically distributed architecture is more complex than shown in the diagram.)

  • Configuration Manager provides a user-friendly interface for manipulating the contact center configuration data that solutions use and for setting user permissions for solution functions and data.

  • The Configuration Database stores all configuration data. DB Server—a Services Layer component—serves as an access point to the Configuration Database.

  • Solution Deployment Wizards automate deployment and upgrade. These Wizards also handle solution-specific data integrity.

  • Management Framework Deployment Manager (not shown in the diagram) provides a user-friendly interface for deploying certain Framework components to both local and unattended remote hosts.

  • Configuration Conversion Wizard (not shown in the diagram) provides a user-friendly interface to migrate Genesys configuration data into 7.6 data format.

  • Configuration Import Wizard (not shown in the diagram) makes it easier to integrate data from external data sources into the Genesys Configuration Database. The Wizard provides a user-friendly interface which enables you to:

    • automatically import agent data from Lightweight Directory Access Protocol (LDAP) and Microsoft Active Directory databases.

    • import switch configuration data from various switches.

Use the Wizard's capabilities to import and export configuration data to and from Extensible Markup Language (XML) files, to generate custom reports from the Configuration Database, and to compare two configuration sets (including import of configuration differences).


Management Layer Overview

Management Layer

Overview: Management Layer

The Management Layer of Genesys Framework provides:

  • Centralized solution control and monitoring. This layer displays the real-time status of every configured Solution object and activates and deactivates solutions and single applications, including user-defined solutions.

  • Centralized logging that records application maintenance events. The unified log format enables easy selection of required log records and centralized log storage for convenient access and solution-level troubleshooting. With centralized logging, you can also track individual interactions, audit activities in your contact center, and store alarm history.

  • Flexible alarm signaling that triggers alarms based on application maintenance events, system performance variables thresholds, or Simple Network Management Protocol (SNMP) variables thresholds. Solution Control Server communicates alarms to Solution Control Interface for display and can write alarms to system logs. You can also configure the system to convert alarms into SNMP traps and send them as e-mails to a specified Internet address. (The latter automatically enables paging notifications.) The Management Layer automatically associates alarms with the solutions they affect and stores alarms as active conditions in the system until either they are removed by another maintenance event or you clear them.

  • Fault-management functions, consisting of detection, isolation, and correction of application failures. For nonredundant configurations, the Management Layer automatically restarts applications that fail. For redundant configurations, this layer supports a switchover to standby applications and automatically restarts failed applications.

  • Built-in SNMP support for both alarm processing and SNMP data exchange with an SNMP-compliant network management system (NMS). This means you can integrate a third-party NMS with a Genesys system to serve as an end-user interface for system control and monitoring and for alarm signaling.

  • Individual host monitoring, including records of CPU and memory usage and information about currently running processes and services.

  • Support for geographically distributed environments.

See also Management Layer Architecture.


Management Layer

Management Layer Architecture

  • Local Control Agent (not shown in the diagram), located on every host that the Management Layer controls and/or monitors, starts and stops applications, detects application failures, and communicates application roles in redundancy context.

  • Message Server provides centralized processing and storage of every application's maintenance events. Events are stored as log records in the Centralized Log Database where they are available for further centralized processing. Message Server also checks for log events which are configured to trigger alarms. If it detects a match, it sends the alarm to Solution Control Server for immediate processing.

  • Solution Control Server is the processing center of the Management Layer. It uses Local Control Agents to start solution components in the proper order, monitor their status, and provide a restart or switchover in case of application failure. Solution Control Server also processes alarms as specified by the user.

  • Solution Control Interface displays the status of all installed Genesys solutions and information about each active alarm, enables the user to start and stop solutions or single applications (including third-party applications), and enables advanced selection and viewing of maintenance logs.

  • The Centralized Log Database stores all Application log records, including interaction-related records, alarm history records, and audit records. DB Server—a Services Layer component—serves as an access point to the Centralized Log Database.

  • Genesys SNMP (Simple Network Management Protocol) Master Agent (an optional component not shown in the diagram) provides an interface between the Management Layer and an SNMP-compliant NMS (Network Management System).


Media Layer Overview

Media Layer

Overview: Media Layer

The Media Layer of Genesys Framework:

  • Provides interfaces to communication media.

  • Distributes interaction-related business data within and across solutions.

See also Media Layer Architecture.


Media Layer

Media Layer Architecture

  • T-Server® provides an interface with traditional telephony systems.

  • Interaction Server provides an interface with internet media, such as e-mail and web communications.

  • SMCP (Simple Media Control Protocol) T-Server provides an interface with voice over IP telephony systems.

All of these servers communicate interaction-processing requests from the Genesys solutions to the media devices and distribute interaction-processing events in the opposite direction. They also maintain the current state of each interaction and all the business data collected about each interaction during processing stages.

These servers distribute attached data to all the applications that participate in processing the interaction. They can also transfer that data across multiple interaction-processing sites.

Another Media Layer component, Load Distribution Server (LDS), not shown in the diagram, increases system scalability and availability. Mediating between T-Servers and T-Server clients, LDS enables an N + 1 architecture, where N is the number of clients that handle the load, in situations where the total traffic of a large installation exceeds the capacity of a single client.


Services Layer Overview

Services Layer

Overview: Services Layer

The Services Layer of Genesys Framework:

  • Provides interfaces for Genesys solutions to various DBMSs (database management systems).

  • Converts events related to management of single interactions into statistical data, which is then used for interaction processing and contact center reporting.

See also Services Layer Architecture.


Services Layer

Services Layer Architecture

  • Stat Server tracks real-time states of interaction-management resources and collects statistics about contact center performance. Genesys solutions use the statistical data to more "intelligently" manage real-time interactions. Through Genesys Reporting, you can use the data to generate real-time and historical contact center reports.

  • DB Server provides the interface between Genesys applications and the DBMS holding the operational databases for solutions.


Redundant Architectures

You can increase the availability of your Genesys solutions by using either redundant or load distribution schema.

You must have special licenses to use these configurations.

Redundant Schema

You can deploy redundant pairs of primary and backup servers of the same type, controlled by the Management Layer.

All Framework servers support the warm standby redundancy type, meaning that a backup server application remains initialized and ready to take over the operations of the primary server.

T-Servers for most types of traditional telephony switches also support the hot standby redundancy type, meaning that:

  • A backup server application remains initialized.

  • Clients connect to both the primary and the backup servers at startup.

  • The backup server data is synchronized from the primary server.

For some switches, you must compensate for the lack of CTI link redundancy by using an additional Genesys component called HA Proxy.

Note: To avoid network overload at backup T-Server startup, only data for newly arrived calls is synchronized to the backup T-Server. Complete synchronization is achieved only when all preexisting calls are disconnected after the backup T-Server starts.

Load Distribution Schema

You can deploy Load Distribution Server (LDS) between T-Servers and some T-Server clients.

Designed to increase system scalability and availability, LDS enables an N + 1 architecture, where N is the number of clients that handle the load, in situations where the total traffic of a large installation exceeds the capacity of a single client.

Note: Interaction Server supports load distribution schema in a similar manner.


Scalable Architectures

You can improve the scalability of your Genesys solutions by using:

  • Distributed configuration environments.

  • Distributed management environments.

  • Load distribution schema.

You must have special licenses to use these configurations.

Distributed Configuration Environments

In a geographically distributed configuration environment, the master Configuration Server is running at the site where the Configuration Database is located. Configuration Servers at multiple remote sites are working in so-called Proxy mode and are connecting to the master Configuration Server.

Distributed Management Environments

In a geographically distributed management environment, Solution Control Servers are communicating with each other and controlling a particular part of the Genesys environment while running at multiple remote sites (but within the same configuration environment).

Load Distribution Schema

  • In an environment with high call volumes, deploy Load Distribution Server (LDS) between T-Servers and some T-Server clients to distribute call load.

Designed to increase system scalability and availability, LDS enables an N + 1 architecture, where N is the number of clients that handle the load, in situations where the total traffic of a large installation exceeds the capacity of a single client.


Framework Connections

The following graphic shows connections that Framework components establish to each other and to solutions. The arrows in the graphic point in the direction from the client to the server in client-server pairs.