About This File

Voice Callback 7 Log Events Help

Copyright © 2001–2005 Genesys Telecommunications Laboratories, Inc. All rights reserved.

71vcb_logevents-help_04-2005_v1.00

[this topic was removed before 71vcb_logevents-help was added to the Combined Log Events Help file.]


Voice Callback (Universal Callback Server) Log Events Overview

VCB Log Events

Voice Callback 7 Log Events Overview

The Voice Callback option for Universal Routing includes the Universal Callback Server.

Universal Callback Server (UCBS) messages report problems or information about server activity. UCBS Log events contain additional information about UCBS messages, including diagnostic information and, when applicable, possible corrective actions. The log event text provides more detailed information than the message text that displays on the screen.

To obtain more information about a message:

  1. Identify the message number within the message on the screen

  2. Select the matching topic in this help document.

Changes to log events from one release to another are also documented. Refer to Voice Callback—Changes from 7.0 to 7.1.


Voice Callback--Changes from 6.0 to 6.1

Voice Callback—Changes from 6.0 to 6.1

There were no Voice Callback log events in 6.0 or 6.1.

All Voice Callback log events are new in the Voice Callback 7.0 release.


Voice Callback--Changes from 6.1 to 6.5

Voice Callback—Changes from 6.1 to 6.5

There were no Voice Callback log events in 6.1 or 6.5.

All Voice Callback log events are new in the Voice Callback 7.0 release.


Voice Callback--Changes from 6.5 to 7.0

Voice Callback—Changes from 6.5 to 7.0

There were no Voice Callback log events in 6.5.

All Voice Callback log events are new in the Voice Callback 7.0 release.


Voice Callback--Changes from 7.0 to 7.1

Voice Callback—Changes from 7.0 to 7.1

This section describes Universal Callback Server log events that were added for release 7.1.

Log Event | Level | Text | Type of Change | Details
92-80000 | Standard | Request to open DataStream: StatServer [server name], StatExtension [extension file name] | Added |
92-80001 | Standard | DataStream opened: StatServer [server name], StatExtension [extension file name] | Added |
92-80002 | Standard | DataStream opening Failure: StatServer [server application object name], StatExtension [extension file name] | Added |
92-80003 | Standard | DataStream Subscription opened: StatServer [server application object name], Object [object name], ActionList [action list] | Added |
92-80004 | Standard | DataStream Subscription closed: StatServer [server application object name], Object [object name], Actions [action code list] | Added |
92-80005 | Trace | DataStream Action sent: StatServer [server application object name], Object [object name], Action [action code] | Added |
92-91000 | Trace | nteraction (ID=[identifier]) created for phone number [phone number], DN [DN name], switch [switch name] | Added | I
92-91001 | Trace | Interaction (ID=[identifier]) updated for phone number [phone number], DN [DN name], switch [switch name]: attempts=[number of attempts], status=[request status], call result=[call result] | Added |
92-91002 | Trace | Interaction (ID=[identifier]) closed for phone number [phone number], DN [DN name], switch [switch name] | Added |
92-91003 | Trace | Cannot create interaction for phone number [phone number], DN [DN name], switch [switch name] | Added |
92-91004 | Trace | Cannot update interaction (ID=[identifier]) for phone number [phone number], DN [DN name], switch [switch name] | Added |
92-91005 | Trace | Cannot close interaction (ID=[identifier]) for phone number [phone number], DN [DN name], switch [switch name] | Added |
92-91006 | Trace | Contact Server error, fault code [fault code] | Added |

See the Log Events Overview section of the Genesys Combined Log Events Help for descriptions of log event parameters.

See the Common Log Events section of the Genesys Combined Log Events Help for descriptions of log events common to all Genesys components.


92-31022

Level | STANDARD
Text | Error during Engage Agent request processing: Library error: Dialer DBID: [DBID value]
Attributes | [DBID value] DBID of CPD Server
Description | Internal message


92-31023

Level | STANDARD
Text | Error during Release all Agents request processing: Library error: Dialer DBID: [DBID value]
Attributes | [DBID value] DBID of CPD Server
Description | Internal message


92-31024

Level | TRACE
Text | Agent successfully engaged: Dialer DBID: [DBID value]
Attributes | [DBID value] Dialer DBID = DBID of CPDServer
Description | An agent was successfully engaged.


92-31025

Level | STANDARD
Text | Engage error: Dialer DBID: [DBID value]
Attributes | [DBID value] DBID of CPD Server
Description | Engaging was unsuccessful.
Actions | Check an agent; check CPDServer and configuration.


92-31029

Level | STANDARD
Text | CPDServer was not found by [socket value]
Attributes | [socket value] socket
Description | OCS cannot find CPD Server by the socket specified in the response from CPD Server.
Actions | Check CPD Server.


92-31030

Level | STANDARD
Text | Call was not found: [SDHandle value]
Attributes | [SDHandle value] Call handle from CPDServer
Description | OCS cannot find a call with the SDHandle specified in the CPD Server response.
Actions | Check CPD Server.


92-50001

Level | STANDARD
Text | TDispatch: Empty TEvent
Attributes | None
Description | An incorrect event was received from T-Server. This may indicate a problem with TCP/IP.
Actions | Check network traffic usage and system memory status. If there are no errors, contact Genesys Technical Support.


92-50005

Level | TRACE
Text | TServer link disconnected: [TServer value]
Attributes | [TServer value] Tserver socket number
Description | T-Server disconnected from link.
Actions | 1. Start backup T-Server. 2. Re-start T-Server. 3. Check TCP/IP connection.


92-50016

Level | STANDARD
Text | Not enough memory
Attributes | No attributes.
Description | Cannot allocate enough memory to continue operation. Server needs more memory.
Actions | Refer to hardware requirements. If additional memory does not solve the problem, call Genesys technical support. Be aware that a software memory leak may be contributing to the problem.


92-50026

Level | STANDARD
Text | Cannot find DN with DBID: [DBID value]
Attributes | [DBID value] DN DBID
Description | Data from Configuration Server is missing. This indicates either a lack of permissions or a corrupted database.
Actions | Check the Outbound Contact 6.5 configuration for correct permissions. Check the Configuration Layer database for potential corruption. If there are no errors, contact Genesys Technical Support.


92-50027

Level | STANDARD
Text | No data for DN with DBID: [DBID value]
Attributes | [DBID value] DN DBID
Description | Data from Configuration Server is missing. This indicates either a lack of permissions or a corrupted database.
Actions | Check the Outbound Contact 6.5 configuration for correct permissions. Check the Configuration Layer database for potential corruption. If there are no errors, contact Genesys Technical Support.


92-50034

Level | STANDARD
Text | Cannot find Switch
Attributes | None
Description | The configuration is incorrect. Outbound Contact Server (OCS) is not able to associate a switch with a T-Server. A T-Server must be associated with a switch.
Actions | Check the Outbound Contact 6.5 configuration and, if necessary, set up the switch. If the switch is set up correctly, contact Genesys Technical Support.


92-50040

Level | TRACE
Text | Initialize and register DN
Attributes | None
Description | Starting procedure of registering all places.


92-50042

Level | STANDARD
Text | Cannot register DN type and DN name: [DN type], [DN name]
Attributes | [DN type] Type of DN (position, extension, ACD, statistic (communication)) [DN name] DN name
Description | This is a configuration error. The DN is not acceptable for registration because of an inconsistent DN description.
Actions | Correct the configuration. If there are no errors, contact Genesys Technical Support.


92-50069

Level | TRACE
Text | Empty User Event data
Attributes | None
Description | This is an internal error.
Actions | Contact Genesys Technical Support.


92-50070

Level | TRACE
Text | DN with DBID does not belong to this Switch: [DBID value]
Attributes | [DBID value] DN DBID (database identification number)
Description | This is an internal error.
Actions | Contact Genesys Technical Support.


92-50071

Level | TRACE
Text | Send UserEvent
Attributes | None
Description | Internal message


92-50072

Level | TRACE
Text | Cannot send UserEvent
Attributes | None
Description | This communication error indicates that Outbound Contact Server (OCS) cannot send user events. There may be network problems or T-Server is not connected.
Actions | Check network traffic usage. If there are no errors, contact Genesys Technical Support.


92-50078

Level | STANDARD
Text | Wrong data for Predictive Call
Attributes | None
Description | This indicates incorrect data. The phone number is missing in the call record or the origination DN is missing in the campaign group configuration.
Actions | Contact Genesys Technical Support.


92-50079

Level | STANDARD
Text | Cannot make predictive call: [record id value]
Attributes | [record id value] record id (identification number)
Description | Either CPD (Call Progress Detection) Server is disconnected or there is an internal error.
Actions | Make sure CPD Server is running. If the CPD Server is running, contact Genesys Technical Support.


92-50080

Level | TRACE
Text | Predictive call: [record id value]
Attributes | [record id value] record id (identification number)
Description | Predictive call was successfully sent.


92-50085

Level | STANDARD
Text | Cannot find T-Server application with DBID: [DBID value]
Attributes | [DBID value] T-Server DBID (database identification number)
Description | This indicates that there are permissions problems or configuration database integrity problems.
Actions | Check T-Server permissions in the Outbound Contact 6.5 configuration; check the database for integrity problems, and then contact Genesys Technical Support.


92-60000

Level | TRACE
Text | [name]
Attributes | [name] Full name of the OCS version
Description | Printing version of OCS


92-60001

Level | STANDARD
Text | OCS is exiting...
Attributes | None
Description | Message before OCS exits.
Actions | Check the reason of a exit.


92-60002

Level | TRACE
Text | OCS is changing status: [previous status value], [new status value]
Attributes | [previous status value] Previous OCS status [new status value] New OCS status
Description | Management layer changed status of OCS (0 – primary, 1 – backup, 2 – exit)


92-60003

Level | TRACE
Text | Campaign name is being activated: [campaign name]
Attributes | [campaign name] Campaign name
Description | A campaign is able to dial calls because backup OCS became primary.


92-60004

Level | TRACE
Text | Campaign name is being deactivated: [campaign name]
Attributes | [campaign name] Campaign name
Description | A campaign stops dialing calls because primary OCS switched to backup OCS.


92-60005

Level | TRACE
Text | Stat Data of campaign name is updated: [campaign name]
Attributes | [campaign name] Campaign name
Description | Updating campaign statistics by backup OCS.


92-61000

Level | STANDARD
Text | Cannot read DONOTCALL Server: [DBMS name[, [database name], [user name]
Attributes | Database access point attributes: [DBMS name] DBMS name [database name] Database name [user name] User name
Description | Error DBEvent from DBServer while reading DONOTCALL table.
Actions | See the DB Server log to define the problem more precisely.


92-61001

Level | STANDARD
Text | Can not open DONOTCALL Server: [DBMS name], [database name], [user name]
Attributes | Database access point attributes: [DBMS name] DBMS name [database name] Database name [user name] User name
Description | Impossible to open DONOTCALL database table.
Actions | Check table access for gsw_request_log.


92-62000

Level | STANDARD
Text | Failed retrieve EWT for DN: StatServer is not configured: [DN name], [server name]
Attributes | [DN name] DN name [server name] StatServer name
Description | The Statserver application is not configured to retrieve Statistics on the specific DN.
Actions | Check StatServer connections. Add proper StatServer to callback configuration object if necessary.


92-62001

Level | STANDARD
Text | Failed retrieve EWT for DN, StatServer: [DN name], [server name]
Attributes | [DN name] DN name [server name] Statserver name
Description | StatServer is configured, but VCB could not open a connection to it.
Actions | Ensure that StatServer is running on the configured host.


92-80000

Level | STANDARD
Text | Request to open DataStream: StatServer [server name], StatExtension [extension file name]
Attributes | [server name] Name of StatServer Application Object [extension file name] Name of Extension Archive File
Description | UCBServer sends request to StatServer to open DataStream.


92-80001

Level | STANDARD
Text | DataStream opened: StatServer [server name], StatExtension [extension file name]
Attributes | [server name] Name of StatServer Application Object [extension file name] Name of Extension Archive File
Description | DataStream opened notification received from StatServer.


92-80002

Level | STANDARD
Text | DataStream opening Failure: StatServer [server application object name], StatExtension [extension file name]
Attributes | [server application object name] Name of StatServer Application Object [extension file name] Name of Extension Archive File
Description | DataStream open failure notification received from StatServer.
Actions | Check StatServer Configuration and Extension deployment.


92-80003

Level | STANDARD
Text | DataStream Subscription opened: StatServer [server application object name], Object [object name], ActionList [action list]
Attributes | [server application object name] Name of StatServer Application Object [object name] Object [action list] ActionList
Description | Subscription opened notification received from StatServer.


92-80004

Level | STANDARD
Text | DataStream Subscription closed: StatServer [server application object name], Object [object name], Actions [action code list]
Attributes | [server application object name] Name of StatServer Application Object [object name] Object Name [action code list] List of applicable Action codes
Description | Subscription closed notification received from StatServer.


92-80005

Level | TRACE
Text | DataStream Action sent: StatServer [server application object name], Object [object name], Action [action code]
Attributes | [server application object name] Name of StatServer Application Object [object name] Object Name [action code] Action code
Description | Action Message has been sent to StatServer.


92-91000

Level | TRACE
Text | Interaction (ID=[identifier]) created for phone number [phone number], DN [DN name], switch [switch name]
Attributes | [identifier] Interaction unique identifier [phone number] Phone number [DN name] DN name [switch name] Switch name
Description | Interaction with specified ID has been created in Universal Contact Server for the callback request to specified phone number, processed on specified switch and DN.


92-91001

Level | TRACE
Text | Interaction (ID=[identifier]) updated for phone number [phone number], DN [DN name], switch [switch name]: attempts=[number of attempts], status=[request status], call result=[call result]
Attributes | [identifier] Interaction unique identifier [phone number] Phone number [DN name] DN name [switch name] Switch name [number of attempts] Number of attempts [request status] Current callback request status [call result] Current call result
Description | Interaction with specified ID has been updated in Universal Contact Server for the callback request to specified phone number, processed on specified switch and DN. Attributes of an interaction are updated as specified.


92-91002

Level | TRACE
Text | Interaction (ID=[identifier]) closed for phone number [phone number], DN [DN name], switch [switch name]
Attributes | [identifer] Interaction unique identifier [phone number] Phone number [DN name] DN name [switch name] Switch name
Description | Interaction with specified ID has been closed in Universal Contact Server for the callback request to specified phone number, processed on specified switch and DN.


92-91003

Level | TRACE
Text | Cannot create interaction for phone number [phone number], DN [DN name], switch [switch name]
Attributes | [phone number] Phone number [DN name] DN name [switch name] Switch name
Description | Universal Callback Server was not able to create an interaction in Universal Contact Server for the callback request to specified phone number, processed on specified switch and DN.
Actions | Determine the reason for this problem. Check if Universal Contact Server is running and if connection to it is maintained by Universal Callback Server. Also check Universal Contact Server's configuration.


92-91004

Level | TRACE
Text | Cannot update interaction (ID=[identifier]) for phone number [phone number], DN [DN name], switch [switch name]
Attributes | [identifier] Interaction unique identifier [phone number] Phone number [DN name] DN name [switch name] Switch name
Description | Universal Callback Server was not able to update an interaction with specified ID in Universal Contact Server for the callback request to specified phone number, processed on specified switch and DN.
Actions | Determine the reason for this problem. Check if Universal Contact Server is running and if connection to it is maintained by Universal Callback Server. Also check Universal Contact Server's configuration.


92-91005

Level | TRACE
Text | Cannot close interaction (ID=[identifier]) for phone number [phone number], DN [DN name], switch [switch name]
Attributes | [identifier] Interaction unique identifier [phone number] Phone number [DN name] DN name [switch name] Switch name
Description | Universal Callback Server was not able to close an interaction with specified ID in Universal Contact Server for the callback request to specified phone number, processed on specified switch and DN.
Actions | Determine the reason for this problem. Check if Universal Contact Server is running and if connection to it is maintained by Universal Callback Server. Also check Universal Contact Server's configuration.


92-91006

Level | TRACE
Text | Contact Server error, fault code [fault code]
Attributes | [fault code] Fault code returned by Universal Contact Server
Description | Universal Contact Server returned specified fault code as a result of the requested operation.
Actions | Check Universal Contact Server's or Universal Callback Server's log for the error description for the given fault code. Determine the reason for the error.